Ruby 3.0 対応へ向けて

昨日につづけて、when_exe Gem を Ruby の最近のバージョンで
動かすための準備をしています。

本日のコミットは、

 https://github.com/suchowan/when_exe/commit/16458040cd12aa10376c94feff724aecf74eecf8

推奨されなくなった "== nil" のようなコードを ",nil?" に直す変更と、
Ruby 3.0 で禁止される OpenURI の open メソッドを生で呼ぶコードの
修正です。

後者はRuby 3.0 で推奨される "URI.open" という書き方が、古い
バージョンでは逆にエラーとなってしまうためトリッキーな書き方
になってしまいました。

今週は、ひきつづきRuby 3.0 対応へ向けての対応を行う予定です。